aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar sommerfeld <sommerfeld@sommerfeld.dev>2024-04-21 16:04:38 +0100
committerLibravatar sommerfeld <sommerfeld@sommerfeld.dev>2024-04-21 16:04:38 +0100
commit1ab6ecba6f509b7b76865d65c77ecebc51efd2d3 (patch)
treea9b92e15769d483560d5799569b14c985b9c3ea5 /Cargo.toml
downloadsentrum-0.1.0.tar.gz
sentrum-0.1.0.tar.bz2
sentrum-0.1.0.zip
Initial commitv0.1.0
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml43
1 files changed, 43 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..ff4d23c
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,43 @@
+[package]
+name = "sentrum"
+version = "0.1.0"
+edition = "2021"
+authors = ["sommerfeld <sommerfeld@sommerfeld.dev>"]
+description = "Daemon that monitors watch-only bitcoin wallets"
+repository = "https://github.com/sommerfelddev/sentrum"
+license = "MIT"
+keywords = ["bitcoin", "notification", "daemon"]
+categories = ["command-line-utilities", "cryptography::cryptocurrencies"]
+
+[features]
+default = ["ntfy", "email", "telegram", "nostr", "desktop"]
+ntfy = ["dep:ntfy"]
+email = ["dep:lettre", "dep:markdown"]
+telegram = ["dep:teloxide"]
+nostr = ["dep:nostr-sdk", "dep:nostr-relay-pool"]
+desktop = ["dep:notify-rust"]
+
+[dependencies]
+anyhow = "1.0.81"
+bdk = "0.29.0"
+chrono = "0.4.37"
+clap = { version = "4.5.4", features = ["derive"] }
+const_format = "0.2.32"
+dirs = "5.0.1"
+human-panic = "1.2.3"
+lettre = { version = "0.11.6", features = ["serde", "tokio1", "tokio1-native-tls"], optional = true }
+log = "0.4.21"
+notify-rust = { version = "4.11.0", optional = true }
+ntfy = { version = "0.4.0", optional = true}
+pretty_env_logger = "0.5.0"
+serde = {version = "1.0.197", features = ["derive"] }
+strfmt = "0.2.4"
+systemd-directories = "0.1.1"
+toml = "0.8.12"
+markdown = { version = "1.0.0-alpha.16", optional = true }
+tokio = { version = "1.37.0", features = ["rt-multi-thread", "signal", "time"] }
+async-scoped = { version = "0.9.0", features = ["use-tokio"] }
+async-trait = "0.1.80"
+teloxide = { version = "0.12.2", optional = true }
+nostr-sdk = { version = "0.30.0", features = ["nip04", "nip05", "nip44", "nip59"], default-features = false, optional = true }
+nostr-relay-pool = { version = "0.30.0", optional = true }