summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLibravatar sommerfeld <sommerfeld@sommerfeld.dev>2024-06-29 23:14:06 +0100
committerLibravatar sommerfeld <sommerfeld@sommerfeld.dev>2024-06-29 23:14:06 +0100
commit50185514c9063ba064920b35218a0f819c5d217c (patch)
tree31b2dbf2a1a1a81f1587c8ee590511852a6d8db3 /Cargo.toml
parent056098b893a05b193afe80de9897f06d36b6c2b4 (diff)
downloadviewercount-50185514c9063ba064920b35218a0f819c5d217c.tar.gz
viewercount-50185514c9063ba064920b35218a0f819c5d217c.tar.bz2
viewercount-50185514c9063ba064920b35218a0f819c5d217c.zip
Guard against unsupported platforms
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f4c0d6a..a21aae2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -20,7 +20,9 @@ nostr-relay-pool = "0.32.0"
nostr-sdk = { version = "0.32.0", default-features = false }
nostr-signer = { version = "0.32.0", default-features = false, features = ["nip46"] }
pretty_env_logger = "0.5.0"
-procfs = { version = "0.16.0", default-features = false }
serde = { version = "1.0.203", features = ["derive"] }
serde_json = "1.0.118"
tokio = { version = "1.38.0", features = ["rt-multi-thread", "signal", "time"] }
+
+[target.'cfg(any(target_os = "linux", target_os = "android"))'.dependencies]
+procfs = { version = "0.16.0", default-features = false }